Графа "Вес" номенклатуры в документе

Задание: В табличную часть документа "Реализация (купля-продажа)" разместить графу "вес", который должен отображаться из номенклатуры при выборе товара и изменяться с введением количества товара. В подвале документа разместить "Итого по весу".

Решение: сейчас документ "Реализация" имеет следующий вид:

  1. добавить новый реквизит в Документ.Реализация.ТабличнаяЧасть: "вес" (тип: число, длина: 15, точность: 3).

  2. на форме документа добавить ревизит в таблицу (поместить в конец). Прописать в свойствах формулу: глПересчетТаблЧасти(Контекст, Форма.ТекущаяКолонка())

  3. Глобальный модуль - Процедура "глПересчетТаблЧасти()" - внести изменения (изменения выделены жирным)

    Если ИмяРеквизита = "Номенклатура"
        Конт.Единица = Номенклатура.ОсновнаяЕдиница;
        Конт.Коэффициент = Конт.Единица.Коэффициент;
        Конт.Вес = Конт.Единица.Вес;

    ИначеЕсли ИмяРеквизита = "Количество"
        Если Конт.Вид() = "Реализация"   Тогда
        Конт.Вес = Конт.Единица.Вес*Конт.Количество;
        КонецЕсли;
    И тоже самое в ИмяРеквизит = "Единица"

    ИначеЕсли ИмяРеквизита = "Единица"
      Если Конт.Вид() = "Реализация"   Тогда
        Конт.Вес = Конт.Единица.Вес*Конт.Количество;
      КонецЕсли;
    Таким образом, при нажатии на кнопку "новая строка" и выборе номенклатуре в графе "вес" будет отображаться вес за одну единицу измерения. При изменении количества вес будет также изменяться.

  4. Сделаем тоже самое при нажатии на кнопку "Подбор".
    Глобальный модуль - Процедура "глОбработкаПодбора"

        Конт.Номенклатура = Номенклатура;
        Конт.Количество = ТаблицаПодбора.Количество;
        Конт.Единица = Единица;
        Конт.Коэффициент = Единица.Коэффициент;
        Конт.Вес = ТаблицаПодбора.Количество * Единица.Вес;
  5. В случае, если вес в номенклатуре не проставлен, количество будет считаться без веса. Вносим изменения туда же (после п. 4).

      Если Единица.Вес = 0 Тогда
        Конт.Вес = 0;
      КонецЕсли;
  6. На форму документа "Реализация" (в слой Подвал) поместить рамку группы (заголовок: Вес (кг.); идентификатор: РамкаВсегоВес).
    Внутрь рамки поместить текст (формула: глФРМ(Итог("Вес")); шрифт: жирный; описание: общий вес всех позиций в документе).

  7. Таким образом, получаем следующий вид документа "Реализация".



  8. Следует добавить реквизит "вес" в документы, в которых пользователь использует кнопку "Подбор" (для исключения ошибки при выборе товара из номенклатуры).
    Следующие документы:
    • ВводОстатковТМЦ
    • ВозвратОтПокупателя
    • ВозвратПоставщику
    • ЗаявкаПокупателя
    • ИнвентаризацияТМЦ
    • ОприходованиеТМЦ
    • ПеремещениеТМЦ
    • ПереоценкаРозница
    • ПоступлениеТМЦ
    • РеализацияПрочее
    • СписаниеТМЦ

Главная

Windows Server 2008 R2

Windows 8

Windows 7

Windows XP

Программы

W W W

1С 7.7 "Торговля и склад"

1С 8.2 "Управление Торговлей"

Железо

Видеомонтаж

Персоны